play版本升级、降级 & dependencies.yml & 一台机器多版本 & 同时运行多个实例

在conf\dependencies.yml文件中可以指定项目使用哪个版本的play framework。如果不指定后面的版本,就是使用服务器上默认安装的play版本。

Application dependencies

require:

  • play 1.2.4

版本升级、降级:要做版本升级、降级,直接修改这里的版本号,然后在下次deploy的时候就会使用新指定的版本来编译和运行项目。

如果dependencies.yml中没有指定版本号,那么使用默认版本。如果默认版本修改了,它仍然使用首次deploy时的版本。要想使用新版本带来的好处,就要在dependencies.ym文件中指定版本号。

参考:Upgrading Your Play! Framework Version on Heroku

一台机器多版本:把多个版本的play安装目录都加入到path中,同时每个版本的play.bat命令改成playVersionNumber.bat

同时运行多个实例:要修改JPDA端口号和执行的HTTP端口号,注意不同版本的修改方式不同。
Play2中JPDA端口号在play.bat文件中修改,修改HTTP端口:先执行play命令到play控制台,然后执行run 9001修改端口(试用成功);或者play “run 9001”(没有试功!)
Play1.2.9中,上述2个参数都在conf\application.conf中修改。jpda.port=8000,http.port=8080